Certain Burned Games wont boot at all on my dreamcast.

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
Posts: 1

Certain Burned Games wont boot at all on my dreamcast.

Post#1 » Fri Feb 01, 2019 10:11 am

(hope this aint to long, just wanted to put enough stuff out of the way first)

So I recently got my first Dreamcast (VA1 incase you're wondering) since I always wanted to know how it feels to have one and me being quite a fan of a lot fo the games it had. However I did not bought my Dreamcast with any GDI games yet, I DID ordered Sonic Adventure and I am waiting for it to arive, but in the meanwhile I decided to burn some CDIs instead (i'll consider GDEmu when I feel the time is right) and I did got quite the amount of games to work and run pretty nicely: Jet Set Radio, Crazy Taxi, Space Channel 5 (Part 1 and 2), Daytona USA 2001, Ecco The Dolphin Defender Of The Future, Sonic Adventure 2 and even a homebrew port of Sonic Robo Blast 2 (....I was curious).

Ok, so this where we get to the post title, the truth is the FIRST game I tried burning was Sonic Adventure 1 and I even burned it twice, I also wanted to try out ChuChu Rocket and burned it 3 times same goes for Soulcaliber and Power Stone 1/2 they all have the same problem! (there is also another disk with that problem which makes it interesting but thats for later), but anyways each Disk just keeps failing, if I power the DC on with the disk in it, it would show the usual DC startup and then keep showing dreamcast logo for about 10 or more seconds before throwing me to the main menu. whats interesting is that it did not thrown me to the CD player so I dont think this has anything to do with lack of Self boot or anything like that. I want to say those are signs that the DC did tried to boot the game, but at the same time I did not hear any screaching noises when it does it like other games.

Now I tried different things like burning using different programs like Disk Juggler and Alcohol 120% (IMGburn along with the CDI patch files seem to do the job fine enough if you ask me) burning different CDI's of the same game , icluding ones from ReviveDC and even Dcres and they still wont work. I even attempted burning a Utopia Disk for the fuck of it. I had a theory that this might be a problem with games which require a lot of asets and require more space (which when you think about it doesnt make sense , that kind of beats the purpose of a CDI image) but that was thrown out the window when I attempted burning the hacked version of Code Breaker. you see that version has 2 disks, one for Code Breaker itself and the other is a boot disk which alows you to use Code Breaker on burned games. how ever for SOME REASON the normal Code Breaker disk would load fine...but the Loader Disk (the one that is literaly like 4MB) suffers from the same issue as SA1 and ChuChu Rocket and the other games.

Now I personaly have narrowed it down to 2 possible solutions:

Bad Quality CD's- you see over here are not many different types of CD brands I can find. the most common one is by Silver Link. now part of me dont want to believe this is the issue because like I said I used those on those other games and they seem to run fine. however I herd that Sony CD-Rs are the most recomanded so i ordered a 25 pack online and i'll test it out when they arive

Laser- yep, I am pretty sure this is the one answer i'll the most out of this, however this is another one that I dont want to believe, because I read that most signs of a dead lasers usualy talk about inconsistency in reading games and other issues in the games themselfs. the games that DO work for me work consistantly every time it loads and I get the same results in loading and gameplay. so it's kind of hard to believe it's the issue, but I could be wrong because I also found posts of people saying that their GDI games also dont load while still loading other games and readjusting the laser is what helped them. despite that I decided to try and mess with the laser anyways, and it did not worked. dont worry I made sure to be careful and made sure everything is back to the way it was before the operation, but if it still didnt worked then perhaps I need a new laser

So that's about all I could figure to do for now, but incase I am missing anything are there any glaring differences between the games I couldnt play and the ones I could? What could possible cause this?, could it be a difference in the games booting process? because this is getting really wierd. especialy with the way Code Breaker works it's just all so random.

EDIT: so somehow I was able to fix it...sorta
Baicly I realized that my problem is that my Dreamcast just cannot play CDI's that use Audio/Data selfboot method, so I looked up more about it and stubled on this lovely toturial:

after getting all the tools and following the guide I succesfuly was able to make both ChuChu Rocket and SoulCaliber run on my Dreamcast, however there is a catch. this works best only for games that dont use CDDA for its soundtrack and so Audio/Data method is necesary. the first time I followed the toturial I tried it on ChuChu Rocket and that game is one of those games unfortunatly. the result is that in order to burn the game I had to extract all the music files out sinse they are all in the first sesion and the game runs well on my DC....just without music (soundeffect work fine tho).

now I decided to try again with SoulCaliber and luckly that game doesnt really rely on DCCA and so it runs perfectly on the Data/Data method, music and everything.

so yeah, while I cant play EVERYTHING, I can still have a nice chunk of games working now. however I am curious to weather I can still somehow convert Audio/Data games without the expense of music.

  • Similar Topics
    Last post

Return to “Support”

Who is online

Users browsing this forum: No registered users