Problem with SD Card Reader

Place for discussing homebrew games, development, new releases and emulation.

Moderator: VasiliyRS

Posts: 2

Problem with SD Card Reader

Post#1 » Fri May 19, 2017 10:12 pm

Some month ago, i ordered on ebay at triple the price of DC-SD (not knowing that existed) an sd card reader for dreamcast. Very happy that it came up in the mail and decided to plunge to play shenmue, i was looking for the game and homebrew on the web, i was feeling pretty sad from the lack of compatibility. Downloaded some iso for a few day then putting them on the sd card and burn a disk of dreamshell.

First problem, my first original DC don't detect anything in the serial port. Trying to troubleshot, tried to use my second DC, new problem, cannot read any CD-R except a Sonic Adventure 2 CD-R... So decide to pot the laser and might had over potted it but now all CD-R work fine, dunno about CD-RW (since it's making it sound way too fucking easy compared to all DC i owned). Dreamshell RC4 detect my SD Card but i have a lot of problem :

-DC stop detecting/read SD Card
-Black screen on loading
-Game menu corrupted

I tried many microsd and microsd to sd adapter and even my single SD Card (blue sandisk 1gb no loading from disk), so now i have a tons of error for any microsd i try. Decide to burn some previous release of Dreamshell (RC4/RC3/Beta4), nothing work or don't work for long, even one time it random rebooted while loading a game. The only thing that worked fast to load into a minimum of a game was an eroge (dangerous toys) which was the one giving me random reboot.

I might had bended the pin of this cheap low quality at 3x the price adapter since i have hard time with the back of the system being on a shelf.

Seem like from one end i have a DC with busted extension port and from another, either a bad reader or incompatible card or simply it's too much has hassle for working fine.

Both dreamcast are MIL-CD compatible NTSC-U dreamcast unmodded. First one from Nov 2000 (a lucky MIL-CD compatible one with 2 in circle on the unknow range of production time for MIL-CD compatibility) and second was made in March 2000 (was playing it safe since i knew about the date and not the number in circle being the true compatibility check).

Did i had done something wrong with the CD-R of CDI file from the official dreamshell website or it's my adapter or my sd or it's because my Dreamcast are unmodded ?

  • Similar Topics
    Last post

Return to “New Releases/Homebrew/Emulation”

Who is online

Users browsing this forum: No registered users