VMU suddenly stopped working

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
User avatar
dark night
Posts: 50

VMU suddenly stopped working

Post#1 » Tue Nov 24, 2020 7:28 pm

Hello, would like to ask if someone has had the same problem as me.

My Dreamcast VMU simply stopped being recognized by the system. I had been playing with my system for a month now, before it was stored in my closed for like two years. Till today everything was fine. The really strange thing is that the VMU still shows the images from the games at its screen normally, it just is not recognized by the system. I tried tearing it apart looking for bad components or solder joints and found nothing, also cleaned the contacts without success. I also tried the same VMU on other controller and the controllers on other ports but none worked. At the system menu the VMU keeps the exclamation icon on but it is not recognized.



PS: Tried to put some CR2032 on the VMU and start it by itself, it turns on normally but when entering the file viewer mode, it gives System Error 40.

  • Similar Topics
    Last post

Return to “Support”

Who is online

Users browsing this forum: No registered users