Question about console reading backups

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
Posts: 1

Question about console reading backups

Post#1 » Fri Feb 14, 2020 10:55 pm

Hi, I have a Dreamcast console that was gifted to me some time ago. In the bottom of the console it had PAL written and the top had a blue spiral, but when I booted it had an orange spiral in the startup logo(I supposed it was a BIOS mod). It also came with a game that worked(backup - NBA2K1) that said SELF-BOOT on the front and DC / US on the back of the cd (pictures at end of post).
The thing is, I have another NTSC Dreamcast console that came with backups and also read the NBA game. None of the discs worked on the PAL console except the one that came with it (NBA2K1).
Today I dissasembled it and, as expected, I found a BIOS mod chip(which had a chip name scraped off-pictures at end of post).I desoldered it and I was greeted to a blue spiral startup logo. I didn't expect the backups to work (which they didn't, most likely because I took out the region mod chip). To my surprise, the NBA game still worked. But, after a while of trying other backups (and failing to read) I came back to NBA, and it wouldn't boot the game. I tried putting the console upside down (to see if there were any problems with the lid), and that seemed to fix the issue, but it still didn't read any other discs. Then (putting the console it its normal position), it managed to boot the game again.
For further testing, I put a music cd in and I let it play, but after a while (10-15 minutes) it stopped abruptly, only to read again the disc and wait for me to press play.
M̶y̶ ̶q̶u̶e̶s̶t̶i̶o̶n̶ ̶i̶s̶,̶ ̶w̶h̶y̶ ̶d̶o̶e̶s̶ ̶t̶h̶e̶ ̶N̶B̶A̶ ̶g̶a̶m̶e̶ ̶b̶o̶o̶t̶ ̶o̶n̶ ̶b̶o̶t̶h̶ ̶N̶T̶S̶C̶ ̶a̶n̶d̶ ̶P̶A̶L̶ ̶c̶o̶n̶s̶o̶l̶e̶s̶ ̶b̶u̶t̶ ̶n̶o̶n̶e̶ ̶o̶f̶ ̶t̶h̶e̶ ̶o̶t̶h̶e̶r̶ ̶b̶a̶c̶k̶u̶p̶s̶ ̶d̶o̶ ̶o̶n̶ ̶t̶h̶e̶ ̶l̶a̶t̶t̶e̶r̶?̶ ̶I̶s̶ ̶i̶t̶ ̶a̶ ̶p̶r̶o̶b̶l̶e̶m̶ ̶w̶i̶t̶h̶ ̶t̶h̶e̶ ̶l̶a̶s̶e̶r̶ ̶(̶c̶a̶l̶i̶b̶r̶a̶t̶i̶o̶n̶?̶)̶,̶ ̶t̶h̶e̶ ̶l̶i̶d̶-̶c̶l̶o̶s̶i̶n̶g̶ ̶d̶e̶t̶e̶c̶t̶i̶o̶n̶,̶ ̶o̶r̶ ̶s̶o̶m̶e̶ ̶s̶o̶r̶t̶ ̶o̶f̶ ̶c̶o̶p̶y̶-̶p̶r̶o̶t̶e̶c̶t̶i̶o̶n̶?̶ ̶A̶n̶y̶ ̶h̶e̶l̶p̶ ̶i̶s̶ ̶w̶e̶l̶c̶o̶m̶e̶d̶.̶ ̶T̶h̶a̶n̶k̶s̶
Edit: it probably is something with the laser calibration and the lid-closing detection, I'll try to fix the lid on the console and use the NTSC one instead.

  • Similar Topics
    Last post

Return to “Support”

Who is online

Users browsing this forum: Bing [Bot]