Dreamcast doesn't see internet settings in games

Technical help for Dreamcast console, accessories and games only. Ask questions and find answers here. For Online help see the Online Forum
User avatar
Posts: 2

Dreamcast doesn't see internet settings in games

Post#1 » Wed Jul 05, 2017 4:38 pm

Good day everyone! [ ISSUE HAS BEEN SOLVED BY NOW :) ]

I have an issue with getting my dreamcast online and would hope someone could help me with it.

So, first of all I have a Japanese dreamcast (in case it matters).

I have no problem booting XDP, and setting up the internet settings (following the william nash and/or Dreamcasticchannel way). I can connect online and browse the web without any issues.

As soon as I quit the software (with or without shutting off the dreamcast) and load up a game, the game says I have not setup my internet settings, which I clearly just setup before and worked for me. :cry:

If I then boot up the webbrowser again it still saved the information I put in and I can still connect to the internet with no problems, but the games don't notice I set it up.

I'd love to get some help with this! Thanks alot and game on! :mrgreen:
Last edited by Dangermuffin on Sun Jul 09, 2017 10:08 am, edited 1 time in total.

Posts: 188

Re: Dreamcast doesn't see internet settings in games

Post#2 » Fri Jul 07, 2017 3:11 am

Yep that happened to me a lot of times when using a PAL dreamcast

Unsure if having a JP Dreamcast matters thou

How I got around this was, manually inputting the connection details via 4x4 evo (when you boot 4x4 evo it will say not internet connection found) this then stored the data and also allowed me to connect to AFO which sometimes had issues.

Let me know how you get on :)
Online Games: PSO | Quake III Arena | Toy Racer | 4x4 Evo | Starlancer | Planet Ring | Maximum Pool

Founder & Lead Editor

The Dreamcast Junkyard
YouTube Editor

User avatar
Black Mesa
Posts: 1462

Re: Dreamcast doesn't see internet settings in games

Post#3 » Fri Jul 07, 2017 11:15 am

I think adding into Quake 3 Arena or Unreal works too. If you use these make sure you but it under Dial up
account 1 and not Dial up account 2

My only theory whats going on is the dreamcast can store two dial up settings, and some games like chu chu rocket for example only see the 1st set of settings. Which if those dont exist then it thinks there are no internet settings.

User avatar
Posts: 2

Re: Dreamcast doesn't see internet settings in games

Post#4 » Sun Jul 09, 2017 7:00 am

Hey there! Thanks for the replies!
I've got some time next week to try this out, I'll make an update by then!
Thanks alot for the responses :) hope it works! Sounds like a good way to try :).

- Earlier than expected Update:

Sooooooooo, thanks to your tips I found out that the issue is that I can't play the original japanese copies of games online, they do NOT see the internet settings. USA burned copies like Quake, 4X4 and Phantasy Star Online DO work online!

So my issue is solved :), thanks! :D Only stupid thing now is that the key and access code on the japanese PSO copy doesn't work on the burned USA version! RIP :(.

  • Similar Topics
    Last post

Return to “Support”

Who is online

Users browsing this forum: No registered users