Page 1 of 1

32X issues

Posted: Mon Mar 19, 2018 6:16 pm
by RetroPTgameR
Hello to all,

Hope that someone from the community can help me :)

I have a Mega Drive 1 and MD2, (PAL) both have RGB cables and also still have the original RF cables.
When i plug my 32X on either one of them, with all cables needed, all i get is a black screen and a shadow image of the game running.
That happens in both MD's and with the RGB cables. With the RF ones, the TV does not even get the signal from the 32X! Well, rarely...

Strange because my 32X always worked fine but was stored for sometime and now i get this problem. And by the way, the cable that connects the MD to the 32X is official...

I opened it, cleaned it, the two connections that connect the two boards are clean.
Did someone had this issue before?

Thanks for the time to read and reply.

Cheers.

Re: 32X issues

Posted: Wed Mar 21, 2018 2:05 pm
by Xiden
Have you cleaned the carts too? Are all the connections extra tight and secure?

If its still not working it may need repair. https://www.facebook.com/mobiusstriptech/ This guy does incredible work and I'm certain he could fix it. He could probably recap your 32X, which might be what it is needing.

Re: 32X issues

Posted: Wed Mar 21, 2018 2:13 pm
by Anonymouse
I have had this issue before. Open up the 32x and remove the two ribbon cables. Clean the contacts with contact cleaner if you have any and reinstall. I would suggest cleaning all the connection ports at the back of the sega consoles with the contact cleaner. It has solved many problems for me.

Re: 32X issues

Posted: Wed Mar 21, 2018 2:58 pm
by Xiden
Anonymouse wrote:I have had this issue before. Open up the 32x and remove the two ribbon cables. Clean the contacts with contact cleaner if you have any and reinstall. I would suggest cleaning all the connection ports at the back of the sega consoles with the contact cleaner. It has solved many problems for me.


This exactly! Forgot all about those dang ribbon cables... Good call!

Re: 32X issues

Posted: Sun Mar 25, 2018 9:02 am
by RetroPTgameR
Anonymouse wrote:I have had this issue before. Open up the 32x and remove the two ribbon cables. Clean the contacts with contact cleaner if you have any and reinstall. I would suggest cleaning all the connection ports at the back of the sega consoles with the contact cleaner. It has solved many problems for me.



Hello,

I already cleaned the ribbon cables and connectors twice but no luck. I did not use a contact cleaner, i will give it a try later.

The connection ports are clean, also checked that...

Re: 32X issues

Posted: Sun Mar 25, 2018 9:07 am
by RetroPTgameR
Xiden wrote:Have you cleaned the carts too? Are all the connections extra tight and secure?

If its still not working it may need repair. https://www.facebook.com/mobiusstriptech/ This guy does incredible work and I'm certain he could fix it. He could probably recap your 32X, which might be what it is needing.



Carts are ok, and connections are tight yes.

I hope it's not the caps, i can do it if needs to be recaped but it will take some time until i have some time to do it.

I will try again to clean the ribbon cables and connectors just to be 100% sure...

Thanks for the link also

Re: 32X issues

Posted: Fri Mar 30, 2018 1:33 pm
by RetroPTgameR
Hi,

I was able to solve the issue!

Apparently there was a problem with the AC adapter plug. I accidentally moved downwards the connection and image appeared.
I cleaned the connection and now everything is working :D

32X still lives :D

Re: 32X issues

Posted: Sat Mar 31, 2018 4:28 pm
by The-Amazing-Mr_V
I'm going try this to mine. It did something similar last time I tried to use it.

Re: 32X issues

Posted: Sun Apr 01, 2018 5:22 pm
by RetroPTgameR
The-Amazing-Mr_V wrote:I'm going try this to mine. It did something similar last time I tried to use it.



Hope you can make it work :)